I am assuming the hapac2 as an AP only is very similar to my capAC device.
I started with the default setup and was able to access and program the unit with relative ease.
I basically added the necessary wifi settings.
The VLAN settings to match what was coming in on eth1 (the trunk port)
Setup the bridge and bridge ports and rules and presto, done!
I kept the default setup which was in AP-WISP Mode.
# dec/07/2018 16:10:13 by RouterOS 6.43 # # model = RouterBOARD cAP Gi-5acD2nD /interface bridge add admin-mac auto-mac=no comment=defconf name=\ bridgeHallway vlan-filtering=yes /interface ethernet set [ find default-name=ether1 ] speed=100Mbps set [ find default-name=ether2 ] disabled=yes speed=100Mbps /interface vlan add interface=bridgeHallway name=Guests_WIFI-v200 vlan-id=200 add interface=bridgeHallway name=Wifi_SDevices_cap2 vlan-id=45 /interface list (dont need to add this but I did to be consistent with all my setups) add name=WAN add name=LAN /interface wireless security-profiles set [ find default=yes ] supplicant-identity=MikroTik add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" mode=\ dynamic-keys name=Hallway_wifi supplicant-identity="" wpa-pre-shared-key=\ ............. wpa2-pre-shared-key=.......... add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" mode=\ dynamic-keys name=devices_only supplicant-identity="" \ wpa2-pre-shared-key=.................... add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" mode=\ dynamic-keys name=HouseGuestsSecurity supplicant-identity="" \ wpa2-pre-shared-key=..................... /interface wireless set [ find default-name=wlan1 ] band=2ghz-b/g/n country=canada disabled=no \ distance=indoors frequency=2442 mode=ap-bridge name=DevicesHallway \ security-profile=devices_only ssid=???? vlan-id=45 vlan-mode=use-tag \ wireless-protocol=802.11 wps-mode=disabled set [ find default-name=wlan2 ] band=5ghz-n/ac channel-width=20/40/80mhz-Ceee \ country=canada disabled=no mode=ap-bridge name=Hallway5G\ security-profile=Hallway_wifi ssid=????????? wireless-protocol=\ 802.11 wps-mode=disabled add disabled=no keepalive-frames=disabled mac-address= \ master-interface=Hallway5G multicast-buffering=disabled name=VisitorWIFI \ security-profile=HouseGuestsSecurity ssid=Guest_Wifi vlan-id=200 \ vlan-mode=use-tag wds-cost-range=0 wds-default-cost=0 wps-mode=disabled /interface bridge port add bridge=bridgeHallway comment=defconf interface=ether1 add bridge=bridgeHallway comment=defconf interface=DevicesHallway (my 2.6ghz WLAN1) add bridge=bridgeHallway comment=defconf interface=Hallway5G (my 5Ghz WLAN2) add bridge=bridgeHallway interface=VisitorWIFI trusted=yes (my 5Ghz VWLAN) /interface bridge vlan add bridge=bridgeHallway tagged=DevicesHallway,ether1 vlan-ids=45 add bridge=bridgeHallway tagged=VisitorWIFI,ether1, vlan-ids=200 /interface list member (again not required but I did this to be consistent across all my devices) add interface=ether1 list=WAN add interface=ether2 list=LAN add interface=Hallway5G list=LAN add interface=DevicesHallway list=LAN add interface=Wifi_SDevices_cap2 list=LAN add interface=Guests_WIFI-v200 list=LAN
Rest pretty much default.