Sub-menu:/interface ethernet poe
This page describes how PoE-Out (Power over Ethernet) feature can be used on MikroTik devices with at least one PoE-Out interface. MikroTik uses RJ45 mode B pinout for power distribution, where the PoE is passed trough pins 4,5 (+) and 7,8 (-). If a device supports powering other devices using PoE-out, then it is recommended to useat least 18Vas the input voltage, except for devices that support multiple output voltages(e.g.CRS112-8P-4S-IN,CRS328-24P-4S+RM,CRS354-48P-4S+2Q+RM).
MikroTik devices can support some or all of the following PoE standards:
IEEE Standards 802.3af/at- Also called PoE Type 1/PoE+ Type 2, are PoE standards Defined by the IEEE. The aim of these standards is to reduce incompatibility between vendors. MikroTik PSE with af/at support is capable of powering both a Type 1 and a Type 2 PD. Valid PD should have PoE-In resistance from 23.75kΩ to 26.25kΩ. MikroTik devices that support af/at standard can also switch to Passive PoE-Out mode. (e.g.CRS112-8P-4S-IN,CRS328-24P-4S+RM,CRS354-48P-4S+2Q+RM.)
Each PoE-Out implementation supports overload and short-circuits detection.
Note:Some MikroTik devices support all of the described standards (e.g.CRS112-8P-4S-IN,CRS328-24P-4S+RM,netPower 16P,CRS354-48P-4S+2Q+RMetc...)
This table can help you choose which PSE device is best suitable for your needs.
Device name |
PoE-Out port count |
Passive PoE |
802.3af/at |
802.3bt |
Power input |
Maximum output per port | Maximum power output, W |
|
---|---|---|---|---|---|---|---|---|
Input 18-30V, mA |
Input 30-57V, mA | |||||||
CSS610-8P-2S+IN |
8 | + | + | - | AC &DC 48-57 V |
1000 | 625 | 140 |
CRS328-24P-4S+RM |
24 | + | + | - | AC | 1000 | 450 | 450 |
CRS354-48P-4S+2Q+RM |
48 | + | + | - | AC | 1000 | 570 | 700 |
CRS112-8P-4S-IN |
8 | + | + | - | DC 18-30V & DC 30-57V | 1000 | 450 | 80 |
netPower 16P |
16 | + | + | - | DC 18-30V & DC 30-57V | 1100 | 600 | 160 |
RB5009UPr + S + |
8 | + | + | - | DC 18-30V or DC 30-57V | 640 | 420 | 130 |
hEX PoE |
4 | + | + | - | DC 18-30V or DC 30-57V | 1000 | 450 | 102 |
PowerBox Pro |
4 | + | + | - | DC 18-30V or DC 30-57V | 1000 | 450 | 102 |
OmniTIK 5 PoE ac |
4 | + | + | - | DC 18-30V or DC 30-57V | 1000 | 450 | 102 |
hEX PoE lite |
4 | + | - | - | DC 18-30V | 1000 | - |
60 |
PowerBox |
4 | + | - | - | DC 18-30V | 1000 | 60 | |
RB260GSP |
4 | + | - | - | DC 18-30V | 1000 | 60 | |
OmniTIK 5 PoE |
4 | + | - | - | DC 18-30V | 1000 | 60 |
PoE Configuration is supported on all MikroTik devices with PoE-Out interfaces, the configurations can be edited from the RouterOS and SwOS interfaces.
RouterOS provides an option to configure PoE-Out over Winbox, Webfig, and CLI, basic commands using the CLI are
Property | Description |
---|---|
print() | Prints PoE-Out related settings. |
export() | export is displayed under/interface ethernet menu. |
monitor(string| interface) | Shows poe-out-status of a specified port, or all ports with/interface ethernet poe monitor [find] command. |
power-cycle(duration:0..1m |; Default:5s) | Disables PoE-Out power for a specified period of time. |
Some MikroTik PoE-Out devices support the global PoE setting which can be configured under/interface ethernet poe settings
menu. Global setting ether1-poe-in-long-cable feature disables strict input/output current monitoring (short detection) to allow the use of PoE-Out with long ethernet cables and/or avoiding improper short-circuit detection.
Property | Description |
---|---|
ether1-poe-in-long-cable(yes | no) | Setting it to "yes" will disable short detection on all poe-out ports. This is potentially dangerous settings and should be used with caution |
Note:Global setting ofether1-poe-in-long-cablecan also affect PoE-Out behavior on PSE which is powered using a DC connector
PoE-Out can be configured under the menu. Each port can be controlled independently.
Property | Description |
---|---|
name() | Name of an interface |
poe-out(auto-on | forced-on | off; Default:auto-on) | Specifies PoE-Out state
|
poe-priority(integer:0..99 | any; Default:10) | poe-priority specifies the importance of PoE-Out ports, in cases when a total PoE-Out limit is reached, interface with the lowest port priority will be powered off first. Highest priority is 0, the lowest priority is 99. If there are 2 or more ports with the same priority then port with the smallest port number will have a higher priority. For example, if ether2 and ether3 have the same priority and over-current is detected then PoE-Out on ether3 will be turned off. Every 6 seconds ports will be checked for a possibility to provide PoE-Out if it was turned off due to port priority. |
poe-voltage(auto | low | high; Default:auto) | A feature that allows us to manually switch between two voltage outputs on PoE-Out ports. It will take effect only on PSE with switchable voltage modes (CRS112-8P-4S-IN,CRS328-24P-4S+RM,netPower 16P,CRS354-48P-4S+2Q+RM). |
poe-lldp-enabled( yes / no;Default:no) | Link Layer Discovery Protocol(LLDP) is a layer-2 Ethernet protocol for managing devices. LLDP allows an exchange of information between a PSE and a PD. |
Note: Enabling poe-lldp in RouterOS 7.8 can potentially solve issues encountered in VoIP setups.
Note: If poe-voltage=auto and poe-out is set to "forced-on", LOW voltage will be used by default. If the PD supports only high voltage, make sure you also set poe-voltage=high when forcing the PoE output.
RouterOS provides a possibility to monitor PD using a ping, and power-cycle a PoE-Out port when the host does not respond. power-cycle-ping feature can be enabled under/interface ethernet poe
menu.
Property | Description |
---|---|
power-cycle-ping-enabled(yes | no; Default:no) | Enables ping watchdog, power-cycles port if a host does not respond to ICMP or MAC-Telnet packets. |
power-cycle-ping-address(IPv4 | IPv6 | MAC; Default: ) | An address which will be monitored. Since RouterOS 6.46beta16, an active route towards PD is required in case an IP address is configured, so make sure PSE can reach the PD. In case the MAC address is specified, PSE will send MAC-Telnet ping requests only from a specified ethernet interface. When configuring abridge vlan-filteringor some way ofVLAN switching, it is recommended to use the IP address for monitoring your PD. |
power-cycle-ping-timeout(time:0..1h |; Default:5s) | If the host does not respond for more than |
power-cycle-interval(time| any; Default: ) | Disables PoE-Out power for 5s between the specified intervals. Not related with the power-cycle-ping feature. |
If power-cycle is enabled,/interface ethernet poe monitor
will show the actual status of the host and time when power cycle will be performed[1]
SwOS interface provides basic PoE-Out configuration and monitoring options, see more details in theSwOS PoEuser manual.
MikroTik devices with PoE-Out controller (not injector) provides port monitoring option./interface ethernet poe monitor [find]
Property | Description |
---|---|
name() | Name of an interface |
poe-out() | Shows PoE-Out settings |
poe-out-status() | Shows current PoE-Out status on port
The delivered voltage at PD is too low for normal powering (for example Vmin =>30V, but provided 24V); PD uses a second power source which has a higher voltage than PSE, so all current is taken from the second DC source, not PSE PoE-Out port;
|
poe-out-voltage() | Displays PoE Voltage which is applied to the PD. |
poe-out-current() | Displays port current (mA) which is drawn by the PD. |
poe-out-power() | Displays PD power consumption |
Ifpower-cycle-ping
feature is used,/interface ethernet poe monitor [find]
will show additional fields:
power-cycle-host-alive:
power-cycle-after:
It is possible to monitor PoE-Out values using SNMP protocol, this requires enabled SNMP on PSE.SNMP Wiki
SNMP OID tables:
SNMP values can be requested also from the RouterOS, for example,snmp-walk
将打印当前马从所有可用PoE-Out ports:
/tool snmp-walk address=10.155.149.252 oid=1.3.6.1.4.1.14988.1.1.15.1.1.5
To get very specific OID value, usesnmp-get
tool (displays current mA on ether3 interface):
tool snmp-get address=10.155.149.252 oid=1.3.6.1.4.1.14988.1.1.15.1.1.5.3
PoE-Out LED behavior can differ between models, but most of them will indicate PoE-Out state on one additional LED. Devices with one voltage output will light:
Models with multiple voltage options can indicate additional information:
By default PoE-Out, eventloggingis enabled and uses "warning" and "info" topics to notify the user about PoE-Out state changes. Log entries will be added to each PoE-Out state change. Important logs will be added with a "warning" topic, informative logs will be added with the "info" topic. When PoE LLDP is enabled, LLDP status updates are available in the device logs, for example:
06:56:50 poe-out,debug ether4 LLDP TLV 25.0W request denied : hw-limit
Possible denial reasons:
To avoid unnecessary logging in cases when PD is not powered because of current-too-low, RouterOS will filter such events, and add one log per every 512 current-too-low events.
Logs can be disabled if necessary:
/system logging set [find topics~"info"] topics=info,!poe-out
/system logging set [find topics~"warning"] topics=warning,!poe-out
To notify a user about important PoE-Out related problems, messages will be shown in Winbox / WebFig and CLI interface fields:
1 RS ;;; poe-out status: overload
ether1 ether 1500 1588 9204 64:D1:54:61:D5:E0
WebFig and Winbox will notify user under interfaces:
If auto-on is selected on PoE-Out interface, then port operates in this strict order:
If forced-on is selected then port operates in this strict order:
If off mode is used, PoE-Out on the port will be turned off, no detection will take place, and the interface will behave like a simple Ethernet port.
It is important to check PoE-Out specification to find out hardware limitations because it can differ between models
PoE-Out ports are limited with max amp values which are supported in particular voltage, usually max current will differ for low voltage devices (up to 30 V), and for high voltage devices (31 to 57 V).
PSE has also a total PoE-Out current limitation which can't be exceeded, even if the individual port limit allows it.
All MikroTik PSE uses the same PoE-Out pin polarityMode B4,5 (+) and 7,8 (-), however other vendors can use opposite or Mode A pinout on PD. Reverse polarity would require using a crossover cable but Mode A PD would require Mode B to Mode A converter.
Note:Passive PD with high input inrush current can result in overcurrent protection on PSE, make sure that PD specification supports powering from PSE (not only from the passive power injector)
PSE has the following safety features:
The auto-on mode is considered safe, it will check if the resistance on the port is within allowed range and only then enable PoE out on the interface. The range is 3kΩ to 26.5kΩ
当电源PoE-Out端口时,constantly checked for overload. If the overload is detected, PoE-Out is turned off on the port to avoid damage to the PD or PSE.
In seconds the PoE Out feature will be turned on again to see if the environment has changed and PD can be supplied with power again. That is important for configurations that are not connected to mains (solar installations, equipment running on batteries due to mains failure) so that when voltage drops - overload will be detected and connected devices turned off. After a while when the voltage level returns to usual operating value - connected equipment can be powered up again.
When power is enabled on PoE-Out port, PSE continuously checks for a short circuit. If it is detected to ensure that there is no additional damage to PD and PSE, the power is turned off on all ports. PSE will continue to check PoE-Out port until the environment returns to normal.
Warning:确保标准不兼容的PDdoes not have the resistance range 3kΩ to 26.5kΩ are not attached, so the PSE would not try to apply power on them
PSE with independent 8-port sections (CRS112-8P-4S-IN,CRS328-24P-4S+RM,netPower 16P,CRS354-48P-4S+2Q+RM) allows PoE-Out to work independently from the RouterOS, this means that you can reboot/upgrade your RouterOS and the PD will not be rebooted.
Note:CRS328-24P-4S+,netPower 16PPoe-Out priorities work independently on each 8 port section!
RouterOS allows us to define priorities on PoE-Out ports, so if your installation is going overpower budget, the PSE will disable less important PD with the lowest priority.
The priority of0is the highest priority,99- lowest
Example of how to set priorities from CLI:
/interface ethernet poe set ether2 poe-priority=10
/interface ethernet poe set ether3 poe-priority=13
/interface ethernet poe set ether4 poe-priority=11
/interface ethernet poe set ether5 poe-priority=14
What will happen when power budget will go over total PoE-Out limit - first if the overload is detected, ether5 will be turned off (lowest priority), then recheck is done and if the still total limit overload is detected next port in priority will be turned off, in this example, ether3 will be turned off. Both of these ports will be reached every few seconds to check if it is possible to turn PoE-Out on for these ports. Power up will happen in reverse order as the power was cut.
if all, or some ports will have the same poe-priority, then port with the lowest port number will have higher priority
/interface ethernet poe set ether2 poe-priority=10
/interface ethernet poe set ether3 poe-priority=10
/interface ethernet poe set ether4 poe-priority=10
/interface ethernet poe set ether5 poe-priority=10
In this example, if the total PoE-Out limit is reached ether5 will be turned off first, then ether4 then ether3 as all of these ports have same poe priority.
PoE-Out ports can be monitored using a command/interface ethernet poe monitor
[admin@MikroTik] > interface ethernet poe monitor [find]
name: ether2 ether3 ether4 ether5
poe-out-voltage: 23.2V 23.2V 23.2V
poe-out-current: 224mA 116mA 64mA
poe-out-power: 5.1W 2.6W 1.4W
Monitor connected PD with power-cycle-ping feature:
/interface ethernet poe set ether1 power-cycle-ping-enabled=yes power-cycle-ping-address=192.168.88.10 power-cycle-ping-timeout=30s
In this example, PD attached to ether1 will be continuously monitored using a power-cycle-ping feature, which will send ICMP ping requests and wait for a reply. If PD with IP address 192.168.88.10 will not respond for more than 30s, the PoE-Out port will be switched off for 5s.
In cases where a PD does not power-up or reboots unexpectedly when powered from your PSE, it's suggested to the first check:
(MAX power consumption of PSE) + (MAX power consumption of all PD) + 10%)
PoE-Out devices which are running RouterOS 5.x can also hold old PoE-Out controller firmware, upgrade to RouterOS 6.x will automatically update the PoE-Out firmware. Changes between 1.x and 2.x PoE-Out controller firmware will result in higher Max-port limits (0.5A to 1A) in case if it's supported by the hardware, also will provide some additional data which can be monitored, and allow to use PoE-Out priorities.
All MikroTik devices which come with RouterOS 6.x already support the latest PoE-Out firmware.